Samstag, 10. Januar 2015

Hardware steht

Carsten hat sich viel Mühe gegeben. Denn nicht nur die Platte im Schaltschrank musste verdrahtet werden, auch der Rest der Säule will angeschlossen sein. Die dicke Zuleitung für maximal 63A geht natürlich auch gleich an den Leitungsschutzschalter. Das gibt dicke Oberarmmuskeln.

Die 32A Seite ist extern noch nicht verkabelt.

Beim ersten einschalten dann die Enttäuschung. Die 32A Seite zeigt alles korrekt an, aber an der 63A Seite zeigt die Säule "Fehler 40" an. Eigentlich eine Meldung des Rechenwerks, das keine Informationen von extern (also vom Raspi kommen). Also erst mal den Raspi gestartet. Tja, nur will der sich partout nicht starten lassen. Also wieder nach Hause fahren und eine neue SD-Karte programmieren, weil man clever wie man war, von der ersten, die nun mittlerweile fehlerhaft ist kein Backup gemacht hat. Glücklicherweise war nur die Boot-Partition defekt, die Daten-Partition war in Ordnung. Bei der Gelegenheit habe ich dem Edimax-USB-WLAN Modul beigebracht als Accesspoint zu arbeiten. Das hat den Vorteil, das einerseits die Säule extern einfach mit einem Laptop konfiguriert werden kann, andererseits kann man aber auch die Ladekurven nach erfolgter Ladung anschauen. Dazu bucht man sich einfach mit seinem Smartphone an der Säule ein und geht mit seinem Internetbrowser auf die Webseite http://192.168.11.2.

So, neue SD-Karte rein, Säule gestartet....  immer noch Fehler 40. Immerhin kann jetzt der Raspi aber schon von außen konfiguriert werden. Es ist also nicht notwendig eine externe Tastatur und einen  Monitor anzuschliessen. Das klappt jetzt locker mit einem Laptop.

Also, woher kommt der Fehler. Erst mal Testimpulse und Resetsignale zum Rechenwerk geschickt. Auf der 32A Seite klappt alles. Die 63A Seite führt zwar Resets aus, zählt aber nicht und zeigt weiterhin "Fehler 40". Also die Zuführungen vom Raspi von Seite 1 (63A) auf Seite 2 (32A) getauscht. Ergebnis: "Fehler 40" auf Seite 1. Also muß der Fehler im Rechenwerk liegen. Dort die Kontakte geprüft. Bei einem Kabel sieht der Anschluß schon etwas seltsam aus. Also durchmessen.... Alles in Ordnung. Platine herausnehmen....  Was soll das bringen? Wir haben doch sowieso keine Schaltpläne. Egal. Alles untersuchen. Und siehe da, diese Platine enthält ein ganzes Sammelsurium von Sicherungen (mindestens 16 Stück). Und eine von diesen Sicherungen war defekt. Also Sicherung getauscht, Säule mit Strom versorgt und eine gute Minute gewartet. Taataa ...  der Fehler ist weg und die 63A-Seite funktioniert wie sie soll.
Dann die nächste Hürde. Der Preis soll geändert werden. Dazu muß an der Säule über eine Folientastatur erst einmal F1 und dann das Passwort 2222 eingegeben werden. Nur reagiert die Säule da auf nichts. Kontakte an der Folientastatur durchmessen bringt auch kein echtes Ergebnis. Die Taste 1 und die Taste 4 reagieren. Sonst ist alles tot. Heißluft auf die Folie und das Teil zerlegen um zu sehen, wo was ist. Tatsächlich kann mit dem Meßgerät an keiner Stelle Durchgang gemessen werden. Keine Ahnung, was da nicht in Ordnung ist. Nach einem Init-Impuls vom Raspi und dem direkten brücken mit Hilfe eines Drahtes ging es dann mit dem programmieren. Ich werde mich jetzt auf die Suche nach einer Ersatztastatur machen. Außerdem spiele ich mit dem Gedanken über einen USB->8 Kanal Schalter für den Raspi die Tastatur auch über den Raspi erreichbar zu machen. Das dürfte letztlich auch einfacher sein, als sich mit dieser Folientastatur rumzuquälen. Damit wäre auch dort die Funktionalität zur Original-Benzin-Säule verbessert.

Blöderweise hatte ich vergessen die Steuerplatinen für die Regelelektronik mit Software zu bespielen. Deswegen liefen die Displays der beiden OpenEVSE Platinen nicht. Gemeinerweise war mir das im Vorfeld nicht bewusst und so hat Carsten einen vormittag damit verbracht herauszufinden, warum die Displays nichts anzeigten. Jetzt war aber alles gut.

Dann noch einen Fahrzeugsimulator anschließen und der Schütz hat angezogen. Dadurch ging dann auch die Power-LED an. Oben beim ersten Bild kann man es in Grün sehen. Heißt: Säule bereit, Strom liegt am Ausganganschluß an.
Rotlicht heißt: es fließt Strom. Und je mehr "Rot", desto mehr Strom.


Die beiden SDM630 Zähler hängen jetzt gemeinsam an einem RS485 Anschluß am Raspi. Auswerten kann ich sie schon. Jetzt muß ich noch ein klein wenig in die Programmierung einsteigen, damit das Rechenwerk mit Daten versorgt wird und damit die Power-LED je nach Leistung "Rot" anzeigt.

Und die Power-LED verdienen ihren Namen zu recht. Da kommt ganz schön Power raus. Das muß aber auch klappen, denn auch bei Sonnenschein muß man das ja erkennen. Und hier sieht man schon gut, welche Leistung dahinter steckt. Obwohl die Schaugläser praktsich "klar" sind, leuchten sie grün bzw. rot.

Kommentare:

  1. Sehr beeindruckend - da fehlt jetzt nur noch das Schild "Blasenfrei zapfen!" :-)

    AntwortenLöschen
  2. Sehr cool. Die ist hoffentlich am 25.04. beim 5. großen Hamburger und Umland E-Community Treffen in Tostedt dabei ! Dort würde Sie sehr gut aussehen und mächtig Eindruck schinden. Wir dürfen zwar "nur" 50A, aber auch das ist schon schnell ...

    AntwortenLöschen